Jump to content

dúvida Asus a45a / k45a, "qcl40 la-8221p rev:1.0", erro de gravação de bios

Rate this topic


wvillao
 Share

Recommended Posts

Olá!

Estou há 06 meses na manutenção de notebook's (e pc's) e, recentemente, peguei um notebook modelo a45a da Asus e a reclamação do cliente é que 'não estava ligando'. Tenho o hábito de limpar todo o equipamento, tirando o pó e depois passo o álcool isopropílico; dreno possíveis energias estáticas, pressionando o power com a placa totalmente 'nua' e depois conecto cpu, memória, cooler, cr2032 e testo. Assim fiz, e depois de alguma insistência, o led (que já estava ligando, mas sempre apagava após uns 6 seg.) permaneceu ligado! Então logo deduzi que daria vídeo e acomodei a placa em seu lugar; conectei o flat do monitor e religuei... deu vídeo! Entrou no setup, pois estava sem hd. Montei tudo e tentei de novo... não deu vídeo! Lembrei que da 1ª vez estava sem hd, o retirei... deu vídeo! Então vi que neste modelo há a possibilidade de atualizar o bios pelo setup, mas só precisava de uma mídia (usei um pendrive) com o arquivo. Estando tudo pronto, religuei a máq., indiquei o local do arquivo no pendrive e a gravação ocorreu normal até 'antes' do check que o programa faz, quando deu erro (vide imagem). Mas tbm marquei bobeira pois até então eu não tinha sabido nada sobre o chip bios, e só depois 'dessa' é que fui ver tudo direitinho, preparar gravador 'offline' (eu configurei um com o Arduino; não tenho do outro; mas grava bem...), baixar datasheet do chip, etc. Então vi que era de 8mb e quando fui gravar, ao usar arquivo de 6mb o gravador não aceitou gravar... Então eu pergunto: 1) por que a Asus sabendo que o chip é de 8mb, disponibiliza arquivo de 4mb (ao descompactar) na página do equipamento?

2) Alguém já conhece esse equipamento, ou já passou por isso? Fechando: após o erro, o notebook continuou funcionando (sem hd) e, inclusive, no menu 'Advanced' do setup, aparece a nova versão gravada; mas depois de algum tempo voltou a funcionar como estava quando chegou: só acende o led por uns 6 seg. e depois desliga; tbm acende normal o led de carregamento da bateria quando é conectada.

Link da página do equipamento:

You are not allowed to view links. Sign in or sign up.

 

ErroGravacaoBios.jpeg

Edited by wvillao
Formatar título do tópico conforme regras do fórum.
Link to comment
Share on other sites

1 hour ago, lsf.farias said:

Ola, o arquivo do site da Asus é apenas uma atualização por isso que ele é menor, tem que gravar o arquivo completo, tem aqui no site.

 

Certo, mas ainda não posso baixar; mas no início do ano eu comprei um pacote contendo esses arquivos e já baixei vários aqui de 8192 KB. Não sei se você conhece, mas tem um software chado UEFITools, gratuito, que nos permite abrir arquivos binários e ver se estão corrompidos ou não. Há certos 'macetes' para editá-los mas ainda 'apanho' com isso. Mas só sei que TODOS os arquivos que baixei, que foram 11, ao abri-los no UEFITools vem indicando isso: "parseFptRegion: FPT partition table header checksum is invalid". Vou ter que aprender a torná-los válidos. Mas se alguém já souber e puder ajudar, será muito bem vindo. Obrigado. 

Nota: Antes de eu cometer o erro de atualização do bios, não achei opção para backup; imaginei que se eu acionasse o início da atualização, seria apresentada esta opção. Enfim, perdi a oportunidade de ter o arquivo original...

Edited by wvillao
Link to comment
Share on other sites

@lojadisk Nessas alturas das pesquisas que tenho feito, descobri um programa chamado "ME Analyzer" o qual verifica a versão do arquivo da bios e mais alguns outros dados a fim de que o profissional procure gravar só a mais atual (há algumas outras coisas relacionadas, mas que ainda não entendi direito... estou chegando lá) e a 'coisa' vai pra um sentido que nos leva a entender que é possível "construir" uma bios nova, original de qualquer equipamento! Vale a pena dá uma olhada; mas sem paciência, sem chance! É o "magnífico mundo" de edição de bios, ainda não muito explorado. Deixo aí alguns links:

ME Analyzer v1.139.0 r205:

You are not allowed to view links. Sign in or sign up.

FD44Editor 0.9.2:

UEFITools:

Link to comment
Share on other sites

@wvillao editar bios requer um bom conhecimento e quanto a isso concordo plenamente, agora se você já tem o arquivo pronto aí o máximo que precisa fazer é dar um clean na ME Region da Bios, que em muitos casos uma BIOS com ME "cheio" atrapalha seu equipamento a dar imagem. MAs se servir de dica, baixe esse arquivo aí que você achou, regrava, (provavelmente vai ter sucesso) e pega esse mesmo arquivo, abra no FD44 Editor e outros programas que você tiver e crie sua bios idêntica a esse arquivo, aí você regrava novamente, se por acaso funcionar você vai começar a entender e ganhar experiência na edição de BIOS.

Link to comment
Share on other sites

@lojadisk eu tinha até me esquecido que eu tinha respondido ao @lsf.farias e mencionado a respeito do UEFITool. Pois é, esse problema que na mensagem ao colega mencionei, parou de aparecer logo após a instalação do chamado 'Atmel Flip', neste link:

You are not allowed to view links. Sign in or sign up.

o qual só instalei após ter lido essa mensagem:

que ensina como atualizar o firmware do Arduino. E na oportunidade, ganhei um melhor funcionamento do UEFITool, por tabela, sem saber que isso iria acontecer. O que me leva a crer que o que corrigiu o problema foi o 'java re' que vem incluso no pacote de inst.. do 'Atmel Flip', o qual lida com arquivos hexadecimais; que por sua vez, arrumou alguma coisa no meu sistema 'win 8.1 64 bits', permitindo que o UEFITool funcionasse normal. "Ou seja, o problema, portanto, não era na confiabilidade do(s) arquivo(s) de bios e sim, no meu sistema!"

 

Mas, na realidade, esse problema anterior do UEFITool estava se 'unindo' com o do FD44Editor (pq tbm estava com problema), ou seja, eu pensava que era um problema só, porque quando o problema do UEFITool se resolveu e o do FD44Editor, permaneceu, entendi que não! O FD44Editor apresenta a mensagem:

 

[Error parsing BIOS data.
$BOOTEFI$ signature not found.
Please open correct ASUS BIOS file.]                     (os colchetes são só pra delimitar)

 

E ao pressionar Ok, os campos do programa FD44Editor permanecem em branco indicando que não está 'puxando' nenhum dado dos arquivos de bios. Ou seja, ainda está faltando algo no meu sistema, mas pelo menos quanto ao 'windows e a microsoft' em si, até onde eu sei está tudo atualizado. Mas vou tentar o JDK, mas se não funcionar, continuarei buscando. Mas se alguém desconfia do que possa ser ou já passou por isso e resolveu, me ajuda aí!

 

Valeu.

Link to comment
Share on other sites

@cristi Tudo bem? Vou tentar fazer um passo-a-passo:

 

1- Ao receber o equipamento, o desmontei, limpei, testei e deu vídeo! E vi que daria pra atualizar o bios por lá;

2- Ao invés de fazer logo um backup do bios, que no meu caso é pelo Arduino (flashrom) e Linux, e tbm requer soldar fiozinhos nos terminais do chip, na expectativa de ser + prático achei que já funcionaria sem precisar disso e depois eu atualizaria o bios via windows;

3- Remontei tudo e deu vídeo só sem o hd;

4- Desliguei a máq., conectei o pendrive c/ o arquivo, liguei, indiquei o local do arq., mas não vi opção para backup. Julguei q. esta opção apareceria depois e dei o start;

5- A opção não apareceu e perdi a oportunidade de ter um backup do arquivo original;

6- No fim do procedimento (a tarja foi totalmente completada) apareceu mensagem de erro na verificação, o que julgo ser de 'checksum';

7- Mesmo assim ainda continuou funcionando e vi constando a nova versão no menu 'main' do setup;

8- Desliguei de um dia p/ o outro e não voltou a dar vídeo;

9- Só então, procedi aos preparativos, q. deveria ter feito no passo 2, para gravar um backup, agora do arquivo SemiOriginal;

10- Realizei backup, gravei outro arquivo completo, de 8192 KB, mas continuou igual, sem vídeo;

11- Pesquisando, fiz download dos UEFITool e FD44Editor, mas quando tentava rodar qualquer um, apresentavam mensagens de que o arquivo de imagem não era válido, seja por uma ou outra razão;

12- O UEFITool apresentava isso:

'parseFptRegion: FPT partition table header checksum is invalid'

e o FD44Editor, isso:

'Error parsing BIOS data.
$BOOTEFI$ signature not found.
Please open correct ASUS BIOS file.';

13- As mensagens de erro me levaram a deduzir que todos os arquivos que eu tinha conseguido não estavam válidos e comecei a procurar como validá-los;

14- Num determinado dia, aleatoriamente, achei esta informação:

You are not allowed to view links. Sign in or sign up.
 a qual, ensina como atualizar o firmware do Arduino. E por esta página, acessei, baixei e instalei o programa 'Atmel Flip' que traz no seu pacote de instalação, o 'java RE';

15- Esqueci disso e continuei com minhas pesquisas de edição de bios;

16- Num certo momento, achei um site que disponibiliza gratuitamente, o arquivo de bios desta placa-mãe referida neste post e, embora inicialmente achei inútil baixar, voltei atrás e decidi fazer um teste;

17- Ao testar o carregamento do arquivo de bios no UEFITool, a mensagem referida acima sumiu... então pensei "finalmente achei!";

18- Testei o arquivo também no FD44Editor, mas a mensagem que este programa apresentava continuou sendo apresentada;

19- Esse resultado me fez ter curiosidade de testar os demais arquivos nos dois programas e em TODOS os arquivos, exatamente, com o FD44Editor, nada mudou, ao passo que o UEFITool não mais apresentou a sua mensagem de checksum inválido em nenhum arquivo! Mas como assim? Do nada?! (não faz sentido) Foi aí que eu me lembrei da instalação do 'Atmel Flip', que vem com o java RE agregado, ter influenciado de alguma forma no meu sistema operacional que está com o windows 8.1 - 64 bits, e permitiu que o UEFITool não detectasse mais erros nos arquivos de bios. Esse Atmel Flip lida com códigos hexadecimais, portanto, alguma relação tem!;

20- O FD44Editor, no entanto, segue com o seu 'bug'. Pesquisando, vi que aqui no fórum já há uma discussão sobre esse mesmo 'bug' do FD44Editor que estou referindo (seguido de solução), mas está na área restrita pra mim. De qualquer forma, vou continuar buscando a solução. Se o 'bug' no UEFITool, que por culpa das configurações 'estranhas' do meu sistema estava acontecendo, foi corrigido, tem que haver uma forma de corrigir o do FD44Editor também!

 

Valeu.

 

################################################

NOTA: Acabei de constatar que não há problema com o FD44Editor. Pois resolvi baixar do site da Asus um mesmo arquivo de bios anunciado em um dos vídeos que assisti sobre edição de bios. Se trata de um arquivo com extensão .cap o qual, não pode ser gravado diretamente com os gravadores externos, mas precisa do arquivo completo. Testei este arquivo com o FD44Editor e os dados do arquivos foram extraídos normalmente para o programa! Portanto, tudo leva a crer que, especificamente, os arquivos de bios desta placa não funcionam com o FD44Editor. Mas não significa dizer que não há possibilidade de fazer funcionar... então é ir tentando descobrir como e/ou usar outros meios.

################################################

Edited by wvillao
acréscimo da expressão 'estava acontecendo' no passo 20.
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

SOBRE O ELETRÔNICABR

EletrônicaBR é o melhor fórum técnico online, temos o maior e mais atualizado acervo de Esquemas, Bios e Firmwares da internet. Através de nosso sistema de créditos, usuários participativos têm acesso totalmente gratuito. Os melhores técnicos do mundo estão aqui!
Técnico sem o EletrônicaBR não é um técnico completo! Leia Mais...
×
×
  • Create New...